Hallo Gast! Bitte registriere dich um Beiträge schreiben zu können und Zugang zu allen Bereichen zu bekommen. Hier registrieren

Auch ohne Registrierung direkt eine Support-Anfrage stellen: Zum Support-Fomular


Threema Safe mit Nextcloud nutzen
#16
Moin
(14.12.2018., 21:27)uwes schrieb: Laut Anleitung bekommt Threema keinen Vollzugriff. In der Anleitung wird ja empfohlen, einen neuen Benutzer anzulegen.
Wenn Du mit App-Passwort arbeitest, bekommt Threema Vollzugriff auf den Account. Das ist zwangsläufig so.

Du kannst natürlich für jede Threema Installation einen eigenen Nextcloud-User anlegen, so wie von rugk vorgeschlagen. Das halte ich aber für unnötig.

Über die Linkfreigabe lassen sich beliebig viele Threema Installationen mit dem selben Nextcloud-Account verwenden (Ich habe mehrere), und jede Installation hat nur Zugriff auf die eigenen Daten.

(14.12.2018., 22:09)rugk schrieb: @Magrathea Hast du das mal ausprobiert?
Ja. Ich nutze das Verfahren schon länger in anderen Kontexten.


(14.12.2018., 22:09)rugk schrieb: Ich denke nämlich, das wird nicht funktionieren, weil Threema ja WebDAV-Zugriff benötigt. Der Link, den du da erstellst, hat aber nur Zugriff über die Web-Oberfläche, ...
Deshalb verwende ich den generierten Link nicht, sondern nutze die Link-ID für die Server-URL und greife damit über das webdav-Interface von Nextcloud zu.
Zitieren
#17
@"Magrathea" Vielen Dank, es funktioniert tatsächlich. Ich passe die Anleitung an…

Ich habe mir auch mal erlaubt, deinen Screenshot dafür zu verwenden.

So, alles angepasst. Auch die Hinweise zu Owncloud habe ich mit aufgenommen.
Zitieren
#18
@"rugk"
(14.12.2018., 12:56)rugk schrieb: Nach @uwes (Danke auch hierfür), muss bei Owncloud die URL etwas angepasst werden. Statt "remote.php/dav/" muss man hier "remote.php/webdav/" schreiben.
Die Link-Methode hat übrigens auch den Vorteil, dass man den Haupt-Ordner beliebig umbenennen kann.
Die URL https://benutzer:kennwort/remote.php/webdav/unterordner... funktioniert auch bei Nextcloud.
Zitieren
#19
(14.12.2018., 22:16)Magrathea schrieb: Moin
Wenn Du mit App-Passwort arbeitest, bekommt Threema Vollzugriff auf den Account. Das ist zwangsläufig so.

Das spielt aber keine Rolle, wenn der Benutzer nur für das Threema-Safe-Backup verwendet wird. Andere Dateien sind dann ja nicht da drin.

(14.12.2018., 20:24)Magrathea schrieb: Moin

Der Test überprüft Lesbarkeit und Inhalt der Datei config. Grundsätzlich ist der Zugriff auf den Server bei Dir also möglich.

Wenn dein Unterverzeichnis "backups" nicht beschreibbar oder nicht vorhanden, passiert anschließend genau das, was Du beschreibst.

So was ist nicht benutzerfreundlich. Es sollte eine Fehlermeldung geben, die beschreibt, woran sich Threema stört.

"Das Verzeichnis backups ist nicht vorhanden." (warum dann nicht gleich anlegen...)
"Das Verzeichnis backups ist nicht beschreibbar."
Zitieren
#20
Kurze Info: Geänderte Anleitung mit der Link Freigabe hat bei mir auf Anhieb mit Nextcloud 14.04 funktioniert. Vielen Dank an rugk und Magrathea.  Top!

kkarsten62
Zitieren
#21
Hallo zusammen,

bin auch gerade dabei, mir einen privaten Server einzurichten.
Hier habe ich zur Auswahl GMX und meine Synology.

Leider bekomme ich das nicht so hin wie gewünscht - habe in meiner Synology einen extra User angelegt.
Bei GMX bekommt einen Freigabelink, welchen ich aber nicht "lesen" kann.

Hier ist mal ein Testordner von GMX

https://c.gmx.net/@324830000995899867/X8...2ZZ_Wy0cQQ (Passwort ist "threema")
Der normale Zugriff erfolgt über folgenden Link - https://webdav.mc.gmx.net

Habe es mal mit Passwort im Link probiert, aber irgendwie gehts net...

Hat jemand eine Idee?

Gruß

(15.12.2018., 17:18)mr-magoo schrieb: Leider bekomme ich das nicht so hin wie gewünscht - habe in meiner Synology einen extra User angelegt.

Habe den Link zu meiner Synology mal gemacht, bekomme aber einen Zertifikatsfehler "trust anchor certification path not found" und daher nicht zugreifen.
https://<user>:<pass>@synology:5006/threematest
Zitieren
#22
(15.12.2018., 12:23)uwes schrieb: So was ist nicht benutzerfreundlich.

Es heisst nicht umsonst "Experten-Einstellungen" Zwincker
Zitieren
#23
(15.12.2018., 19:03)Claus schrieb: Es heisst nicht umsonst "Experten-Einstellungen" Zwincker

Auch mit Experten darf man freundlich umgehen...
Zitieren
#24
Hm - irgendwas klappt nicht. Vielleicht sieht jemand von Euch, was mir die Tomaten auf den Augen verbergen?

Ich hab mich für Linkfreigabe á la Magrathea für meinen existierenden Nutzer in Nextcloud 15.0 entschieden. Verzeichnis Threema/ erstellt, config-Datei erstellt, Ordner backups/ erstellt, Linkfreigabe mit Paßwort (Hochladen und bearbeiten erlaubt) erstellt.
Wenn ich diesen Link jetzt im Desktopbrowser aufrufe bekomme ich den Paßwortscreen eingeblendet -> eingeben -> Ordner Threema/ wird wie erwartet angezeigt.

Wenn ich die Link-ID nach Schema umbaue
Code:
https://<Link-ID>:<$password>@mein.server.fnord/public.php/webdav/
, dann bekomme ich von Nextcloud 'unauthorized' angezeigt.

Die URL in Threema eingegeben erzeugt eine Fehlermeldung "HTTPS IO Exception" mit der anschließenden Ausgabe der URL mit angehängtem /config

Details:
  • ich nutze NGinX mit PHP 7.2-fpm, die Verbindung läuft unter TLS 1.3 (Relevanz? Problem tritt auch im Desktopbrowser auf)
  • mein Paßwort beinhaltet ein Komma
  • im Access-Log des Servers wird mir ein GET public.php/webdav/ mit Status 401 verzeichnet
  • das Error-Log bleibt leer
Any hints anyone?
Zitieren
#25
Moin
Dein Problem ist die "HTTPS IO Exception".
Vermutlich will dein Webserver HTTPS Parameter vorschreiben, die dein Smartphone nicht unterstützt.

Reduziere mal die Anforderungen
Code:
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers 'ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256';
Zitieren
#26
(15.12.2018., 17:18)mr-magoo schrieb: Habe den Link zu meiner Synology mal gemacht, bekomme aber einen Zertifikatsfehler "trust anchor certification path not found" und daher nicht zugreifen.
https://<user>:<pass>@synology:5006/threematest
Das hatte ich zunächst auch. Dagegen hilft es, dass Synology CA Zertifikat auf dem Smartphone zu installieren. Auf der DiskStation dazu unter Systemsteuerung / Sicherheit / Zertifikat das "Zertifikat exportieren", dann syno-ca-cert.pem aus dem erzeugten ZIP vom .pem-Format ins .der-Format konvertieren (das habe ich mit Firefox gemacht: .pem importiert, und dann als .der exportiert), auf's Smartphone übertragen und Zertifikat dort installieren.

Allerdings erhalte ich nun ständig in Threema die Fehlermeldung: "Test fehlgeschlagen: HTTPS IO Exception: Connection closed by peer", obwohl eigentlich alles passen sollte?! Username, Passwort (Sonderzeichen darin URL-codiert), und Port (5006) stimmen (https://username.passwort@192.168.178.2:...d/zum/safe) und das Verzeichnis dort auf der DiskStation enthält auch die korrekte config-Datei und das "backups"-Verzeichnis - allesamt mit Schreibrechten für den Nutzer...
Hat jemand eine Idee, was mir diese Fehlermeldung sagen möchte?

Andy
Zitieren
#27
Hm. 
Laut SSLlabs sollte ab Android 7.0 TLS 1.2 unterstützt sein, und das spricht mein Server auch - hier der Auszug aus der SSL-Analyse:

Zitat:[font=Arial, Helvetica, sans-serif]Android 7.0    RSA 2048 (SHA256)     TLS 1.2 > h2     TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384   ECDH secp384r1  FS[/font]

Und, was mich noch viel mehr wundert - es klappt auch auf dem Desktop nicht (Chrome 71, Firefox 64, Opera 57, alles unter Linux))

Aber ok - ich hab dem Server gesagt, TLS 1.2 ist das höchste der Gefühle, und die Ciphers auch etwas eingegrenzt:
Code:
ssl_protocols TLSv1.2;
ssl_ciphers ECDHE-RSA-AES256-GCM-SHA512:DHE-RSA-AES256-GCM-SHA512:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384;

Restart - gleiches Bild, auch mit TLS 1.2: auf dem Desktop bekomme ich von Nextcloud 'nen Fehler "unauthorized" und unter Android (8.1) innerhalb Threemas kommt die HTTPS IO Exception. 
Chrome auf Android verlangt dann Username/Passwort.

Kann es am PHP-FPM bzw. wie das eingebunden ist liegen? Config ist direkt copy/paste aus dem Nextcloud-Manual kopiert
Zitieren
#28
Schnelle Bestätigung von mir: habs gerade nach der aktualisierten Anleitung auf einer frischen NC15-Instanz gemacht, hat einwandfrei funktioniert.

+1, tausend Dank für die gute Dokumentation!
Zitieren
#29
Hallo,

ich kann das Problem von von Husky nur bestätigen.


Zitat:Hm - irgendwas klappt nicht. Vielleicht sieht jemand von Euch, was mir die Tomaten auf den Augen verbergen?

Ich hab mich für Linkfreigabe á la Magrathea für meinen existierenden Nutzer in Nextcloud 15.0 entschieden. Verzeichnis Threema/ erstellt, config-Datei erstellt, Ordner backups/ erstellt, Linkfreigabe mit Paßwort (Hochladen und bearbeiten erlaubt) erstellt.
Wenn ich diesen Link jetzt im Desktopbrowser aufrufe bekomme ich den Paßwortscreen eingeblendet -> eingeben -> Ordner Threema/ wird wie erwartet angezeigt.

Wenn ich die Link-ID nach Schema umbaue
Code:
Code:
https://<Link-ID>:<$password>@mein.server.fnord/public.php/webdav/
, dann bekomme ich von Nextcloud 'unauthorized' angezeigt.

Die URL in Threema eingegeben erzeugt eine Fehlermeldung "HTTPS IO Exception" mit der anschließenden Ausgabe der URL mit angehängtem /config

Details:
  • ich nutze NGinX mit PHP 7.2-fpm, die Verbindung läuft unter TLS 1.3 (Relevanz? Problem tritt auch im Desktopbrowser auf)
  • mein Paßwort beinhaltet ein Komma
  • im Access-Log des Servers wird mir ein GET public.php/webdav/ mit Status 401 verzeichnet
  • das Error-Log bleibt leer

Any hints anyone?


Details:
  • Apache mit PHP 7.2-fpm unter TLS 1.2 auf Sub-domain
  • Nextcloud 14.0.4
  • Passwort enthällt ein $ (mit %24 habe ich es auch versucht)
  • Error-Log leer.
Wenn diese Kinderkrankheiten noch behoben werden und vielleicht die config-Datei und der backups-Ordner automatisch angelegt werden, ist diese Funktion richtig gut (Aber für mich jetzt leider noch nicht einsetzbar).
Zitieren
#30
Hallo,

meine Erfahrung ist wie folgt:

ich habe einen Account "Threema_User" mit einem Passwort "Passwort" auf meiner Nextcloud angelegt.

Dann mußte ich nur noch im Threema

Code:
https://Threema_User:Passwort@nextcloudserver.com/remote.php/dav/files/Threema_User/threema_safe

einsetzen und schon wurde der Server erkannt. 

Es ist aber darauf zu achten keine Sonderzeichen im User oder Passwort zu verwenden, da sich Threema ansonsten beim laden der URL verschluckt. Ich weiß nicht ob oder wie man in einer URL Worte einklammern kann, vielleicht weiß ja hier jemand ob es etwas gibt wie ' ` " um klar zu machen, dass das Passwort ein abgeschlossener String ist. Dann kann man auch wieder starke Passwörter nutzen.

Ein  Top! für eine separate Eingabemaske für User und Passwort bei der Servereingabe in der Threema GUI. Und schon jetzt ein  LetsRock für den Threema-Safe, coole Sache.

Christian

P.S. Bitte, bitte Feedback, wenn ich groben Mist schreibe, aber nett bitte.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Threema Safe: "User Agent Validation" mibere 5 1.932 13.05.2019., 11:40
Letzter Beitrag: rugk
  Sekurŝranko: Threema Safe Backup-Server dbrgn 1 1.221 14.12.2018., 14:05
Letzter Beitrag: rugk
  Threema am PC nutzen [RemixOS] m0Do. 3 3.553 19.09.2016., 18:22
Letzter Beitrag: andyg
  Threema vom PC aus nutzen MrExtremeSwiss 39 51.493 06.08.2016., 14:48
Letzter Beitrag: lgrahl