Hallo Gast! Bitte registriere dich um Beiträge schreiben zu können und Zugang zu allen Bereichen zu bekommen. Hier registrieren

Auch ohne Registrierung direkt eine Support-Anfrage stellen: Zum Support-Fomular


Update auf PHP 7 > keine Funktion mehr
#1
Servus, hab gestern von Debian 8 zu 9 und dann zu 10 geupdatet.
damit ging einher, dass die DB auf MariaDB umgestellt wurde und PHP auf Version 7 Pflicht ist.
Nun läuft leider meine API nicht mehr.
Die testSendSimple.php bleibt komplett blank als wär ein Bug drin.

Habe bereits alle Seiten überprüft ob der Short Tag überall long ist (war auch eine Änderung) aber die passen.
Auch sonst fällt mir nichts auf.
Jemand ne Idee?

Edit: Local in der Commandline des Linux, mit threema-msgapi-tool.php läuft es aber
Zitieren
#2
Was sagt denn das Error-Log?
Entweder nutzt Du eine Funktion, die es bei PHP7 nicht mehr gibt oder Du nutzt eine Option in der Konfiguration, die nicht mehr unterstützt wird. Das sagt Dir aber das error-Log genau.
Zitieren
#3
Guten Morgen, die Logs meckerten über cURL.
Leider hab ich das unter 7.0 nicht aktiviert bekommen.
Habe dann PHP 7.2 aktiviert, dann lief alles.
Dachte aber, das wenn es local läuft nur an irgendwelchen Sicherheitssachen liegen könnte.
Echt eine Fleißattacke diese Umstellung. Also in anderen Sachen Threema läuft super zuverlässig.
Zitieren