Hallo Gast! Bitte registriere dich um Beiträge schreiben zu können und Zugang zu allen Bereichen zu bekommen. Hier registrieren

Auch ohne Registrierung direkt eine Support-Anfrage stellen: Zum Support-Fomular


Threema Web für iOS: Betatest eröffnet
#46
Du kannst im Testflight unter Previous Builds einfach die Build 2320 wieder installieren. Dann hat man über was Wochenende eine funktionierende Version Zwincker
Zitieren
#47
(22.06.2018., 20:04)lichtbote schrieb: ...verbinden ja, aber die Chats werden nicht geladen. Der "Ladekreisl" dreht seine Runden ohne das was passiert.... im Moment nicht nutzbar. Feedback bereits geschrieben.
Das habe ich auch, allerdings schon seit der vorherigen Beta.
Der "Ewigkeits–Kreisel" betrifft aber nur den zuerst geöffneten Chat, nicht jedoch die folgenden Chats: es hilft bei mir in diesem Fall, einfach einen anderen Chat anzutippen und dann wieder den eigentlichen Chat, dann öffnet er. Ist das bei Euch auch so?

Andy
Zitieren
#48
(23.06.2018., 07:47)andyg schrieb: Das habe ich auch, allerdings schon seit der vorherigen Beta.
Der "Ewigkeits–Kreisel" betrifft aber nur den zuerst geöffneten Chat, nicht jedoch die folgenden Chats: es hilft bei mir in diesem Fall, einfach einen anderen Chat anzutippen und dann wieder den eigentlichen Chat, dann öffnet er. Ist das bei Euch auch so?

Andy

Ja, hatte ähnliches Verhalten festgestellt. Mit der neue Beta (2322) wird kein Chat mehr geladen oder max. der Erste. Werde aber nicht downgraden, warte auf die nächste Version. Im Moment ist es mehr ein testen; ein produktives nutzen ist aus meiner Sicht noch nicht gegeben.
Zitieren
#49
Code:
[Error] Failed to load resource: the server responded with a status of 404 () (angular-sanitize.min.js.map, line 0)
[Error] Failed to load resource: the server responded with a status of 404 () (angular-route.min.js.map, line 0)
[Error] Failed to load resource: the server responded with a status of 404 () (saltyrtc-task-relayed-data.es5.js.map, line 0)
[Error] Failed to load resource: the server responded with a status of 404 () (angular-aria.min.js.map, line 0)
[Error] Failed to load resource: the server responded with a status of 404 () (messageformat.min.js.map, line 0)
[Error] Failed to load resource: the server responded with a status of 404 () (angular-animate.min.js.map, line 0)

Das könnte einer der Gründe sein wieso es bei mir nicht lädt ^^
Zitieren
#50
Ich habe übrigens das Problem, dass ich vorherige Web-Sitzungen nicht mit dem Passwort wiederherstellen kann. Obwohl ich beim Herstellen der Verbindung zwischen iPhone und Firefox (kurz: FF) mittels QR-Scan ein entsprechendes Passwort vergebe, muss ich nach einem Neustart von FF wieder einen neuen QR-Code scannnen. Das Wiederherstellen der vorherigen Sitzung mittels Passworts gelingt mir nur in der aktuellen FF-Sitzung, nicht jedoch, wenn FF neu gestartet wurde (z.B. nach einem PC-Reboot).

==> Vermitung: Da die Sitzungs-Wiederherstellung unter Safari (iOS/iPad) als Browser hingegen einwandfrei funtioniert, vermute ich, dass Firefox die entsprechenden Sitzungsdaten beim Beenden von FF einfach löscht.

In den FF-Privacy-Einstellungen habe ich folgende Einstellungen gesetzt, von denen ich annahm, dass sie sich auf das Problem beziehen könnten (insbesondere die gesetzte Ausnahmeregel für web(-beta).threema.ch) - was allerdings leider nicht der Fall war:
Firefox unter Extras / Einstellungen / Datenschutz und Sicherheit:
   
Unter Ausnahmen ist dort folgendes eingetragen:
   

Kennt ihr dieses Problem? Hat jemand eine Idee, wo ich noch nach einer passenden Einstellung suchen könnte?

Andy

Threema: 4.0 (Beta 2322) unter iOS 11.4/iPhone X
Web-Client:  Version 2.0.0-beta.5 (unter Windows 10 64Bit)

[EDIT]
Auch mit dieser experimentellen Einstellung - Cookies und Website-Daten behalten: bis sie nicht mehr gültig sind (anstatt "bis FF beendet wird"); Website-Daten von Drittanbietern akzeptieren: immer  - stellt sich übrigens keine Besserung ein:
   
Nach FF-Neustart erscheint immer der QR-Code...

(23.06.2018., 12:38)lichtbote schrieb: Ja, hatte ähnliches Verhalten festgestellt. Mit der neue Beta (2322) wird kein Chat mehr geladen oder max. der Erste. Werde aber nicht downgraden, warte auf die nächste Version.
Ich erhalte nun ein eher uneinheitliches Bild.
Positiv: der erste Chat wird nun (bis jetzt) zuverlässig geöffnet! Freuen 
Negativ: es kommt vor, dass innerhalb einer Sitzung einzelne Chats sich absolut weigern, geladen zu werden; so nach dem Motto: wenn ein Chat beim Laden einmal "hängt", dann "hängt" er in dieser Sitzung für immer. Da helfen auch keine einen-anderen-Chat-anklicken-und-wieder-zurück-Maßnahmen (die zuvor manchmal funktionierten). Erst ein Beenden der Sitzung mit anschließender Neuverbindung lässt dann ein Zugriff auf den Chat zu...

Bisher kein zuverlässigen Reproduktions-Mechanismus entdeckt (tritt "manchmal" bei "manchen" Chats auf).


Zitat:Im Moment ist es mehr ein testen; ein produktives nutzen ist aus meiner Sicht noch nicht gegeben.

Ja, stimmt, zumindest noch. Aber: es wird von Tag zu Tag besser! Die anfänglichen Verbindungsprobleme sind jedenfalls deutlich weniger geworden! Top!

Andy


Angehängte Dateien Thumbnail(s)
   
Zitieren
#51
(24.06.2018., 20:42)andyg schrieb: Ich habe übrigens das Problem, dass ich vorherige Web-Sitzungen nicht mit dem Passwort wiederherstellen kann. ...

Ich hab das erneute Öffnen der Web-Sitzungen mit Passwort prinzipiell aufgegeben und starte die Websitzungen immer mit neuem Scannen des Codes. (allerdings habe ich Android).
Klar - Ausnahmen einfügen ist gut und schön - und größtenteils funktioniert das auch.
(IMHO hatte es damals trotzdem nicht immer 100% geklappt, aber hab es lange nicht mehr probiert. Außerdem braucht man ja die Ausnahmen sowohl für ThreemaWeb und BetaThreemaWeb)

Bei mir gibt es aber zusätzlich noch das "Problem", dass die ccleaner Pro und Steganos Privacy Suite benutze, die zusätzlich noch intensiver putzen - unabhängig von den Firefox-Einstellungen.
Hab eigentlich kein Problem damit, den Code immer neu zu scannen. Man muss eben ab und zu mal die vielen "unbekannten Sitzungen" in ThreemaWeb löschen. Sowas bedingt eben sowas - und Nachteile gibt es immer mal...
Zitieren
#52
Wenn der QR-Code erneut gescannt werden muss, bedeutet das, dass der "local storage" für die Domain gelöscht wurde. Häufig passiert das beim Schliessen des Browsers, wenn man "Cookies beim Löschen des Browsers" aktiviert hat.

Hilft ev. das hier? https://threema.ch/de/faq/web_browser_settings
Zitieren
#53
(25.06.2018., 07:54)dbrgn schrieb: Wenn der QR-Code erneut gescannt werden muss, bedeutet das, dass der "local storage" für die Domain gelöscht wurde. Häufig passiert das beim Schliessen des Browsers, wenn man "Cookies beim Löschen des Browsers" aktiviert hat.

Dachte ich auch und hatte ich deshalb deaktiviert — wie gesagt leider ohne Erfolg (siehe oben)
Zitat:
Hilft ev. das hier? https://threema.ch/de/faq/web_browser_settings
Ach herrje, an die FAQ hab ich gar nicht gedacht (dabei verweise ich ja selbst gerne darauf)! <Facepalm> Vielen Dank!!
Werde die dort empfohlenen Einstellungen nachher gleich mal überprüfen!

[EDIT]

Mit den vorgeschlagenen Einstellungen der FAQ geht es nun!


Andy
Zitieren
#54
Aber mit dem Herstellen der Verbindung zum Firefox hakt es leider immer noch öfters... Klappt oft nicht, insbesondere, wenn das iPhone lange Zeit im Standby ist. Manchmal erscheinen auch plötzlich 2 neue Sitzungen nach den QR-Scannen?! Kurz drauf stürzt die App dann ab, oder es kommt einfach keine Verbindung zustande...

Und grad eben hatte ich zwei Nachrichten im Webclient geschrieben und gesendet, die blieben jedoch nur im Ausgang des Webclients (Status: Pfeil nach oben); sie erschienen jedoch nicht (!) im Chatverlauf der App - geschweige denn kamen sie beim Empfänger an. Offenbar wurden sie nicht von Webclient an die App weitergegeben. Das ist sehr ärgerlich!

PS: und natürlich waren der Balken in grüner Farbe, und ich konnte auch zwischen verschiedenen Chats hin- und herwechseln. Eine Verbindung hat technisch also zwischen App und Webclient bestanden, nur das übermitteln der Nachricht klappte irgendwie nicht. Ist mir leider schon mehrfach passiert…

Andy
Zitieren
#55
Wie sieht es bei euch eigentlich mit dem aufwecken der App aus? Bei mir hats bei Build 2320 relativ gut (gefühlt 90% der Fälle) funktioniert, aber seit 2322 und 2323 funktioniert das Aufwecken der App nur noch sehr unzuverlässig (gefühlt weniger als 50% der Fälle).
Bei mir läuft aber auch die iOS 12 beta auf dem Handy und darum weiss ich nicht ob es daran liegt.

(26.06.2018., 06:39)andyg schrieb: Und grad eben hatte ich zwei Nachrichten im Webclient geschrieben und gesendet, die blieben jedoch nur im Ausgang des Webclients (Status: Pfeil nach oben); sie erschienen jedoch nicht (!) im Chatverlauf der App - geschweige denn kamen sie beim Empfänger an. Offenbar wurden sie nicht von Webclient an die App weitergegeben. Das ist sehr ärgerlich!

Mit der neuen Beta zeigt der Webclient wenigstens an wenn die Nachricht nicht verschickt wurde.
Zitieren
#56
Hallo schuschu,
(26.06.2018., 09:36)schuschu schrieb: Wie sieht es bei euch eigentlich mit dem aufwecken der App aus? Bei mir hats bei Build 2320 relativ gut (gefühlt 90% der Fälle) funktioniert, aber seit 2322 und 2323 funktioniert das Aufwecken der App nur noch sehr unzuverlässig (gefühlt weniger als 50% der Fälle).
Bei mir läuft aber auch die iOS 12 beta auf dem Handy und darum weiss ich nicht ob es daran liegt.
Ich bin mir nicht sicher, ob es seit 2320 besser oder schlechter geworden ist; das Verbindungsverhalten ist irgendwie sehr "launisch": Oft funktioniert es es wider Erwarten problemlos (z.B. nach langen Standby, da rechne ich schon immer mit Problemen), aber oft funktioniert es leider auch wieder nicht - trotz gefühlt "optimaler" Bedingungen (selbes WLAN, Display noch eingeschaltet etc.). Von einer objektiven Verschlimmerung möchte ich aber nicht sprechen.

Das häufigste Symptom beim missglückenden Verbindungsaufbau ist bei mir übrigens, dass der "Prozent-Kreis" ab 5% recht schnell bis 60% uind dann 80% "hochschießt" (d.h. die App sollte eigentlich ausgewacht sein, oder?), aber dann geht's in 2%-Schritten bis 90% und dann in 1%-Schritten bis 100% - wo es dann schlussendlich mit der Fehlermeldung, ob das iPhone Netz hat etc., erfolglos abbricht.

Und das Problem, dass sich Chats nicht öffnen lassen (Stichwort: Dauerkreisel), besteht leider auch immer noch... muss mich teilweise X-mal neu verbinden, bis er endlich den Chat lädt...

Andy

PS: ich sehe grad, dass der Webclient nun " Version 2.0.0-beta.6" anzeigt. Ich meine, erst kürzlich noch "beta.5" gesehen zu haben. Ist hier vielleicht auch kürzlich auch eine neue Version herausgekommen?
Zitieren
#57
Der unzuverlässige Nachrichtenempfang des Webclients nimmt nach den unzuverlässigen Verbindungsaufbau den 2. Platz auf meiner nach Nervigkeit sortierten Bug-Liste ein (Platz 3 wäre übrigens das langsame Tippen):
  • während ca. 30 Minuten Abwesenheit vom PC (Webclient im FF derweil geöffnet) sind jetzt gerade neue Threema-Mitteilungen eingetroffen, die ich am iPhone direkt gelesen habe.
  • Als ich soeben zum PC zurückgekehrt bin, findet sich im Webclient jedoch keine Spur dieser neuen Mitteilungen. Sie sind im betreffenden Chat schlicht und ergreifend nicht vorhanden!
  • Es hilft auch nicht, neu in den Chat hineinzuwechseln (also einen anderen Chat anzuklicken und wieder zum eigentlichen Chat zurückzukehren) - selbst dann findet kein richtiger "Refresh" statt und der Chat bleibt auf dem alten Stand.

Einziger mir bekannter Workaround: Sitzung beenden und neu Starten... erst dann findet ein echter Refresh statt.
Da ich jetzt dazu nicht mehr ständig den QR-Code neu scannen muss (Sitzung speichern im FF klappt ja nun), ist das nun wenigstens nicht mehr ganz so nervig und schnell erledigt. Unschön ist das aber alle mal!


Andy
Zitieren
#58
Die sollen die Beta-Phase gerne auf weitere Monate verlängern und schön fixen. Ganz prinzipiell scheint Threema mit dem Web-Client enorme Probleme zu haben, die Qualität dieses Produkts ist der App meilenweit unterlegen.
Zitieren
#59
(26.06.2018., 17:06)andyg schrieb: Hallo schuschu,
Ich bin mir nicht sicher, ob es seit 2320 besser oder schlechter geworden ist; das Verbindungsverhalten ist irgendwie sehr "launisch": Oft funktioniert es es wider Erwarten problemlos (z.B. nach langen Standby, da rechne ich schon immer mit Problemen), aber oft funktioniert es leider auch wieder nicht - trotz gefühlt "optimaler" Bedingungen (selbes WLAN, Display noch eingeschaltet etc.). Von einer objektiven Verschlimmerung möchte ich aber nicht sprechen.

Das liegt aber oft auch an iOS. Mit diesen Problemen kämpft WhatsApp manchmal auch. Aber etwas Optimierungsbedarf besteht noch.

(26.06.2018., 17:06)andyg schrieb: Das häufigste Symptom beim missglückenden Verbindungsaufbau ist bei mir übrigens, dass der "Prozent-Kreis" ab 5% recht schnell bis 60% uind dann 80% "hochschießt" (d.h. die App sollte eigentlich ausgewacht sein, oder?), aber dann geht's in 2%-Schritten bis 90% und dann in 1%-Schritten bis 100% - wo es dann schlussendlich mit der Fehlermeldung, ob das iPhone Netz hat etc., erfolglos abbricht.

Ich glaube das ist so geplant. Null bis zwölf Prozent ist die Verbindung zum Handy, dann bis 60% wird die Verbindung aufgebaut (geht meistens schnell), ab 60% wird die Konfiguration ausgetauscht und ab 80% geht dann der tatsächliche Datenaustausch los. Ich bin mir nicht sicher wie man das verständlicher umsetzen könnte.

(26.06.2018., 17:06)andyg schrieb: PS: ich sehe grad, dass der Webclient nun " Version 2.0.0-beta.6" anzeigt. Ich meine, erst kürzlich noch "beta.5" gesehen zu haben. Ist hier vielleicht auch kürzlich auch eine neue Version herausgekommen?

Jup, heute morgen. Mit den folgenden Änderungen:

v2.0.0-beta.6 (2018-06-26)
Changes:
  • [feature] Show three blue dots for verified Threema Work contacts

  • [feature] Implement non-work indicator for Threema Work users

  • [feature] Add message timeout state

  • [feature] Show a title text for all message state icons

  • [bug] Ignore status messages when marking as unread

  • [bug] Fix "unread messages" indicator
    https://github.com/threema-ch/threema-we...ANGELOG.md

(26.06.2018., 18:11)andyg schrieb: Der unzuverlässige Nachrichtenempfang des Webclients nimmt nach den unzuverlässigen Verbindungsaufbau den 2. Platz auf meiner nach Nervigkeit sortierten Bug-Liste ein (Platz 3 wäre übrigens das langsame Tippen):
  • während ca. 30 Minuten Abwesenheit vom PC (Webclient im FF derweil geöffnet) sind jetzt gerade neue Threema-Mitteilungen eingetroffen, die ich am iPhone direkt gelesen habe.
  • Als ich soeben zum PC zurückgekehrt bin, findet sich im Webclient jedoch keine Spur dieser neuen Mitteilungen. Sie sind im betreffenden Chat schlicht und ergreifend nicht vorhanden!
  • Es hilft auch nicht, neu in den Chat hineinzuwechseln (also einen anderen Chat anzuklicken und wieder zum eigentlichen Chat zurückzukehren) - selbst dann findet kein richtiger "Refresh" statt und der Chat bleibt auf dem alten Stand.

Ich behaupte das wird sich alles lösen sobald der iOS Client nicht mehr zwischendurch abstürzt.

(26.06.2018., 18:27)Crixus schrieb: Die sollen die Beta-Phase gerne auf weitere Monate verlängern und schön fixen.

Das hängt wohl stark davon ab wo die Probleme liegen. Falls es ein grundsätzliches Problem der Plattform ist, dann sehe ich auch eher Monate als Wochen. Aber wenn es nur noch die Abstürze der App sind, dann geht es keinen Monat mehr.

(26.06.2018., 18:27)Crixus schrieb: Ganz prinzipiell scheint Threema mit dem Web-Client enorme Probleme zu haben, die Qualität dieses Produkts ist der App meilenweit unterlegen.

Wenn man sich Gmail, Wire oder auch WhatsApp Web anschaut, dann sieht es bei Threema gar nicht so schlecht aus.
Zitieren
#60
Wenn's einen Crash in der App gibt, ist es logisch dass Nachrichten verloren gehen, die App weiss ja dann nicht mehr, auf welchem Stand Threema Web ist.

Die Beta-Phase heisst nicht umsonst Beta-Phase. Wenn's keine Crashes mehr geben würde, wär's ja keine Beta mehr Zwincker
Zitieren