Threema Web Session kann mit Firefox 92.0.1 (linux) nicht erstellt werden.

Stelle deine Frage öffentlich an die Threema-Forum-Community - über 3.000 Mitglieder helfen dir weiter. Los gehts!
Unterstützung von offizieller Seite erhältst du direkt bei Threema: Zum offiziellen Threema-Support
  • Seit meinem letzten Firefox-Update kann ich keine Threema-Web-Sitzung mehr initiieren. Es scheint ein FF-Problem zu sein, da ich mit Opera keine Probleme hatte. Auch ein Löschen des FF-Profils inklusive aller plugins bringt keine Abhilfe. Wenn ich den QR-Code scanne, fängt der runde Fortschritts-„Balken“ in FF an fortzuschreiten, bei 60% ist aber Schluss und es kommt die Meldung „Verbindungsaufbau scheint länger zu dauern als normal …“

  • Auch ein Löschen des FF-Profils inklusive aller plugins bringt keine Abhilfe.

    Hallo und willkommen im Forum :)


    das habe ich auch hin und wieder. Hast Du schon versucht, die aktuelle Sitzung zu löschen und eine neue zu erstellen? Besteht das Problem auch im Fehlerbehebungsmodus? Falls ja, besteht das Problem auch in einem neuen, frischen Testprofil ohne jegliche Änderungen und/oder Erweiterungen?


    Gruß Ingo

  • das habe ich auch hin und wieder. Hast Du schon versucht, die aktuelle Sitzung zu löschen und eine neue zu erstellen? Besteht das Problem auch im Fehlerbehebungsmodus? Falls ja, besteht das Problem auch in einem neuen, frischen Testprofil ohne jegliche Änderungen und/oder Erweiterungen?


    Gruß Ingo

    Das Problem tritt bei dem Versuch auf, eine neue Sitzung zu erstellen. Und ja, auch mit einem frischen Testprofil, wie ich schon schrieb und du zitiertes. :)

    Mittlerweile ist die neuste Version von Firefox 93.0. Uns sind aber keine allgemeinen Probleme in 92 oder 93 aufgefallen.


    Die Tipps von Ingo helfen sicher das Problem einzugrenzen. Zusätzlich haben wir noch einen Diagnose-Modus in Threema Web: https://web.threema.ch/troubleshoot/


    Laufen dort alle Tests erfolgreich durch?

    Danke für den Tipp mit dem Diagnose-Modus. Nein, es laufen nicht alle Tests durch: Are WebRTC DataChannel connections possible? scheint den Test nicht beenden zu können, es ist andauernd die Aktivitätsanzeige zu sehen und im grauen Kasten darunter:

    RTCPeerConnection available

    RTCDataChannel available

    Als letztes steht:

    Does TURN work?

    No


    It looks like TURN traffic is being blocked by your firewall.

    Without TURN, connections can only be established if your computer

    and your phone are in the same network.


    Results:

    mit leerem grauen Kasten. An meiner Firewall sollte es nicht liegen, denn mit Opera funktioniert es ja. Auf einem Zweitrechner mit gleichem Betriebssystem (opensuse tumbleweed x64) habe ich noch eine gespeicherte Sitzung, die sich starten lässt. Habe nicht ausprobiert, diese zu löschen und eine neue zu erstellen, weil ich diese Sitzung nicht auch noch verlieren möchte. Ach ja, Telefon und Rechner befinden sich im gleichen (häuslichen) Netz.


    PS: Sorry, dass ich jetzt erst antworte. Ich dachte, ich bekäme eine Email, wenn jemand auf meine NAchricht antwortet.

  • Hast du jemals etwas an about:config geändert? Ist vielleicht media.peerconnection.turn.disable auf true gesetzt? (Ist Standardmässig auf false.) So weit ich weiss werden im Fehlerbehebungsmodus nicht alle Parameter in about:config auf die Standardwerte zurückgesetzt.

    Nicht in letzter Zeit. Und media.peerconnection.turn.disable steht auf false. Die einzige Einstellung mit peerconnection, die nicht auf ihrem Standardwert steht (bzw. fett ist), ist app.normandy.startupRolloutPrefs.media.peerconnection.mtransport_process. Dies ist offenbar kein Standard-Parameter, da er beim Umschalten von true auf false weiterhin fett bleibt und ich ihn entfernen könnte. Wenn ich das tue, ändert sich allerdings am Fehler nichts. Der andere Rechner, auf dem es noch funktioniert, hat den troubleshoot-Test mit überall grünen Haken bestanden. Wie gesagt, das ist das gleiche Betriebssystem. Und auch am betroffenen Rechner geht es ja mit opera immer noch. Sehr mysteriös! Gibt es noch about:config-Einstellungen, die ich checken sollte?

  • Hab ich mal angehängt. Allerdings ist nicht alles zu sehen, sondern nur unten die fehlerhaften Test,, weil mein Bildschirm nicht hoch genug ist.

    Aber das Fehlerbild wird immer merkwürdiger. Ich hatte ja gesagt, dass ein Löschen des Profils nichts ändert. Das ist nicht ganz korrekt. Das „Löschen“ bestand darin, dass ich firefox als root gestartet habe und dort das vorhandene Profil im Profilmanager gelöscht und auch ein neues angelegt habe. Damit hatte ich dann dasselbe Fehlerbild. Da ich „als root starten“ über „kdesu“ gemacht hatte, lief der Windowmanager immer noch unter meinem normalen Login. Jetzt fiel mir ein, dass ich noch einen Testuser auf dem System hatte. Für den ebenfalls über kdesu FF gestartet, hatte ich wieder denselben Fehler. Ich habe danach das bereits vorhandene alte (aber nie benutzte) Profil des Testusers gelöscht und wie bei root ein neues erstellt. Mit diesem Profil funktionierte es plötzlich. Daraufhin habe ich mich richtig als root am Window-Manager eingeloggt, um zu vermeiden, dass dieser auf irgendwelche Ressourcen meines normalen Logins zugreift, aber auch damit hatte ich den Fehler.

    Fazit: ein normaler User mit frischem Profil hat das Problem nicht, ich mit meinem alten Profil und root mit einem neuen haben es. Ich will logischerweise jetzt nicht mein komplettes Profil löschen, zumal ich nicht einmal sicher sein kann, dass das das Problem lösen würde (siehe root). Vielleicht liegt es an irgendwelchen Gruppenzugehörigkeiten. Mein normales Login hat mehr davon als der Testuser, und root darf ja eh alles. Warum allerdings mehr Berechtigungen zu dem Fehler führen sollten, ist mir schleierhaft.

  • Inzwischen habe ich auch die Version 93. Und ich habe nicht nur Probleme mit Threema Web, sondern auch mit test.webrtc.org oder lichess.org. Beide Webseiten schaffen es, ff zum einfrieren zu bringen. Das ist auch auf dem zweiten Computer der Fall. Wenn das so weiter geht, werde ich wohl einen anderen Browser nehmen müssen. Nur komisch, dass es offenbar sonst niemanden trifft. Vielleicht liegt es ja an opensuse und deren Nutzer benötigen betroffene Webseiten nicht, so dass es nicht auffällt.

  • Also am den PCs/Laptops nehme ich nur die App von Langhard.ch. Die geht über Chrome.


    Den Firefox hab ich persönlich schon ewig nicht für sowas mehr genommen.

    Und da es tatsächlich immer mal Probleme mit den neueren Firefox-Versionen gibt, habe ich mir die ESR-Version installiert und habe separat im Ausnahmefall noch eine portable Version am laufen.


    Edit: Probleme mit Firefox gab es aber bei mir nicht mit Threema Web, sondern mit anderen Funktionen.

    __________________________
    Gruß - Miaz (diverse Android-Handys: Samsung Galaxy S20 FE 5G, Samsung Galaxy S7; Sony Xperia Z1C; Threema seit 08/14; Closed-Beta seit 02/18)

    Einmal editiert, zuletzt von Miaz ()

  • Klingt so, als gäbs in deiner Systemkombination Probleme mit WebRTC. Hier lohnt eventuell mal eine Suche in bugzilla.mozilla.org/

    In der Tat, ich habe gerade diesen Bug gefunden, allerdings kein FF Bug an sich sondern einer mit opensuse. Habe den dortigen Workaround angewandt, der zwar mein Problem mit dem Einfrieren zu beheben scheint, aber webrtc funktioniert immer noch nicht richtig. Inzwischen fahre ich mit zwei Profilen, ein ganz leeres nur für threema web. Mit letzterem geht es manchmal...