Threema Desktop Client - openMittsu

Stelle deine Frage öffentlich an die Threema-Forum-Community - über 3.000 Mitglieder helfen dir weiter. Los gehts!
Unterstützung von offizieller Seite erhältst du direkt bei Threema: Zum offiziellen Threema-Support
Threema für Desktop verfügbar! Jetzt runterladen und ausprobieren: Zum Download
Reduzierter Preis für die Ukraine: Threema ist ab sofort im ukrainischen Google Play Store fast kostenlos: 💙💛 mehr Infos 💙💛

  • Nach längerer Zeit habe ich gestern ein Update installiert. Entweder sind die Versionen nicht kompatibel oder wichtige Daten wurden überschrieben. => Keine ID und keine Kontakte.


    Wie richte ich jetzt openMittsu ein? Auf ein Backup kann ich nicht zugreifen.


    • Was war deine letzte Version vor dem Update? Welche Platform?
    • Wenn es vor 0.9.9 war, sollte der First Use Wizard dich eigentlich durch den Import leiten - deine ID war in der alten Version in einer Client Configuration gespeichert (du kannst dort deinen Backupstring + Passwort per Text Editor auslesen, ist Plaintext), diese kann der "Database -> From Backup" Wizard auch direkt einlesen.
    • Deine Kontakte waren ebenfalls in einem Plaintext File gespeichert, dies kannst du dann in die (geladene) Datenbank importieren via "Database -> Import legacy...".

    Solltest du die Dateien nicht finden, schreib mir eine PN, eventuell finden wir eine andere Lösung. Aber _eigentlich_ sollte der First Use Wizard deinen Anwendungsfall genau abdecken. Komisch.




    Neu buildet qt5-sqlcipher bei mir nicht mehr:


    > Cannot mix incompatible Qt library (version 0x50902) with this library (version 0x50903)
    > /home/danilo/.pkg/qt5-sqlcipher-git/PKGBUILD: line 36: 26418 Aborted (core dumped) ./qsqlcipher-test


    Kommt man da irgendwie darum herum? Ich nutze Arch Linux (rolling release), da wird's immer wieder mal ein Qt update geben.


    Ich bin verwirrt - du versuchst das Plugin (qt5-sqlcipher) zu bauen, richtig? Die Meldung sagt, dass deine installierte Qt5 Version 5.9.2 ist, aber das Plugin gegen Version 5.9.3 gebaut wurde (ich glaube so rum ist es...). Hast du zwei Versionen von Qt5 installiert? Eigentlich (!) sollte ein Plugin, gebaut gegen 5.9.2 auch ohne Probleme mit Qt 5.9.3 laufen, d.h. du musst das Plugin nicht zwangsläufig updaten.
    Aber hier scheint es liegen andere Dinge im Argen - könntest du einmal einen sauberen Rebuild machen (alle CMake Files löschen, neu cmake'n und bauen) und dann kurz erläutern, wie es zu der Situation kommt? Ich kann das Problem noch nicht ganz nachvollziehen.

  • Builden geht:



    Aber beim Test gibt's die Exception:



    Linking:


    Code
    $ ldd qsqlcipher-test  | grep -i qt
            libQt5Sql.so.5 => /usr/lib/libQt5Sql.so.5 (0x00007f77243c5000)
            libQt5Core.so.5 => /usr/lib/libQt5Core.so.5 (0x00007f7723cd3000)
    $ ldd sqldrivers/libqsqlcipher.so  | grep -i qt
            libQt5Sql.so.5 => /usr/lib/libQt5Sql.so.5 (0x00007ff352da4000)
            libQt5Core.so.5 => /usr/lib/libQt5Core.so.5 (0x00007ff3523fd000)


    Ich habe Qt 5.9.3 installiert.


  • Builden geht:



    Aber beim Test gibt's die Exception:



    Okay, das ist ein Hinweis. Anscheinend wurden einzelne Module von Qt nicht rekompiliert, d.h. werden noch in 5.9.2 ausgeliefert.
    In einem Thread zu Arch (hier: https://bbs.archlinux.org/viewtopic.php?id=227943) wird auf diese Lösung verwiesen: https://wiki.archlinux.org/ind…l_to_run_after_Qt5_update


    Es ist also kein Problem in OpenMittsu, sondern in Arch - jetzt weiß ich wieder, warum ich Debian Stable nutze :P


    Sollte es dann immer noch Fehler geben, solltest du einmal alle Versionen checken (was ist der Name der so.x.y.z in /usr/lib/, wurden alle Plugins (auch die Platform Plugins) zeitgleich aktualisiert oder ist eins älter?

  • Das im Wizard angegebene Format der ID hatte mich irritiert. Das fängt im Beispiel an mit: htt...
    Ich hatte das mit "http" assoziiert und so ein ID Backup kenne ich vom Windows Phone nicht.


    Hat sich also erledigt.

    [Beta-Tester] - Nokia Lumia 920 - Windows 10 - Threema 3.0.0.2 | Nokia 7 Plus - Android 9 - Threema 4.0

  • Hallo Philipp,


    erst einmal DANKE, dass du doch noch eine Version für x86-Maschinen bereit stellst. :)
    Allerdings merkt man schon, dass die neue Version eher für schnelle Maschinen gebaut ist. Bei der heutigen neuen Verison, wo Du erstmals eine .exe bereit gestellt hast, hat OpenMittsu über 1 Std. gebraucht, bis man damit arbeiten konnte. Der Kreis hat sich gedreht (also openMittsu hat gearbeitet) und es kam immer die Meldung "keine Rückmeldung".


    Nun zu meinen von mir beobachteten Fehlermeldungen:


    1.) Beim ersten Start kommt immer noch die Meldung das die "msvcr120.dll" nicht vorhanden ist. Ich hab dann einfach die "msvcr120.dll" aus dem alten openMittsu-Verzeichnis ins neue Verzeichnis kopiert und es hat funktioniert. :)


    2.) Ich hatte beim importieren der Daten aus einem anderen OpenMittsu-Verzeichnis nicht die Möglichkeit ein anderes (neueres) Verzeichnis auszuwählen.


    3.) Bei den Gruppen ist oben leider keine Übersicht mehr, welche IDs / Namen in der Gruppe sind.


    4.) Früher hat beim Eintreffen einer Nachricht der entsprechende Tab rot geblinkt. Dies ist jetzt leider nicht mehr so. Man sieht also nicht mehr wo eine neue Nachricht eingetroffen ist, wenn man mehrere Tabs offen hat.


    5.) Wenn man in der Kontaktübersicht eine ID editiert, ist die Änderung erst bei einem Neustart von openMittsu sichtbar.


    6.) In unregelmässigen Abständen werden vom Gruppenersteller Zwei Nachrichten gesendet. In der Ersten die IDs der Gruppenmitglieder und in der zweiten Nachricht dann der Gruppenname. (siehe Screenshot)


    7.) Nachdem man ja jetzt, wegen der verschlüsselten Datenbank, keinen Zugriff mehr auf die Kontakte und Gruppen hat, ist es leider nicht mehr möglich, alte IDs oder Gruppen zu entfernen.

  • Mir sind heute noch 2 Fehler aufgefallen:


    1.) Wenn man einen Link anklickt, dann wird kein Browser geöffnet, ist also ohne Funktion.


    2.) Als ich heute openMittsu gestartet habe, wurden in einer Gruppe alle 3 Sekunden "Pseudonachrichten" gesendet. D.h. laut openMittsu wurden zwar Nachrichten gesendet, aber (zum Glück) wurden die nicht wirklich gesendet. Ein Screenshot ist unten mit angehängt. Der Screenhot zeigt nur einen ganz kurzen Ausschnitt.
    Erst bei einem Neustart von openMittsu wurden keine neuen Pseudonachrichten mehr gesendet.

  • Zu meinem Screenshot in Beitrag #367 habe ich soeben festgestellt, dass das erscheint, wenn der Gruppenersteller die Gruppe neu syncronisiert! :)
    Das ist also wahrscheinlich gar kein Bug, sondern ein(e) "Hinweis / Info", dass die Gruppe neu syncronisiert wurde! :)

  • Frohe Weihnachten allerseits :)



    1) Sollte behoben sein, neue Version von OpenSSL. Die x86 Version braucht noch Runtimes von Visual Studio 2015, da Qt x86 nur für VS2015 vorhanden ist.


    2) Das kann ich leider nicht nachvollziehen, ich gucke demnächst noch einmal.


    3) Durch Rechtsklick auf die Gruppe in der Liste links gibt es das noch. Aber ich werde darüber nachdenken, dass wieder irgendwo zu platzieren.


    4) Ja, das Tab-blinken ist aktuell kaputt/nicht vorhanden. Steht auf der ToDo Liste.


    5) Ist behoben.


    6) Das sind, wie richtig geschlussfolgert, GroupSyncs/Creation Nachrichten, also Steuernachrichten. Diese werden in den neueren Versionen noch ein wenig mehr erklärt, das war sehr rudimentär. Sorry.


    7) Ja und nein. Mit Tools wie "DB Browser for SQLite" kannst du die Datenbank öffnen, da dieses Tool auch SQLCipher unterstützt. Aber ich setze Kontakte löschen auf die ToDo-Liste!



    Zu meinem Screenshot in Beitrag #367 habe ich soeben festgestellt, dass das erscheint, wenn der Gruppenersteller die Gruppe neu syncronisiert! :)
    Das ist also wahrscheinlich gar kein Bug, sondern ein(e) "Hinweis / Info", dass die Gruppe neu syncronisiert wurde! :)


    Jenau!



    Bei mir werden auch leere Nachrichten von meiner Seite und die Gruppensynchronisationsnachrichten als normale Nachrichten angezeigt.


    Ausserdem ist die Performance seit einigen Tagen richtig schlecht.


    Ich dachte das wäre behoben, ich gucke mir das nochmal an und hebe sie eventuell anders hervor.


    Was meinst du mit Performance? Ist es durch ein Update schlechte geworden? Wenn ja welches? Oder was ist langsam?

  • Was mir noch aufgefallen ist, aber nicht erst seit der Verschlüsselung, sondern auch in allen anderen Versionen:


    Wenn man openMittsu ein paar Tage nicht nutzt und in einer Gruppe dann viele Nachrichten geschrieben wurden, kommen die Nachrichten beim "ersten" Start nicht alle an. Erst beim zweiten Start von openMittsu kommt dann der "Rest" der Nachrichten.

  • Mal eine Frage in die Runde:


    Läuft openMittsu bei euch lahm und träge?


    Bei mir ist openMittsu total langsam geworden. Wenn man openMittsu startet und online geht braucht es eeeewig (ca. 30-40 Min.) bis man was schreiben kann. Dann, wenn man schreiben kann, hängt openMittsu auf einmal mittendrin und es dauert wieder ein paar Sekunden bis man wieder schreiben kann. Derzeit ist openMittsu bei mir leider völlig unbrauchbar :/ :(


    Wie sieht es bei euch aus?

  • So!
    Jede Menge neuer Features, mehr Speed und Bugfixes...


    Neue Version: openMittsu_0.9.11plus62-gfeea57a


    Windows Binaries:


    Debian 9 Binaries: Siehe https://downloads.openmittsu.de/deb/ für Pakete plus Anleitung.
    Jetzt mit i386, armhf (Raspberry Pi) und amd64!


    Ich freue mich auf Rückmeldung!


  • Jede Menge neuer Features, mehr Speed und Bugfixes...


    Neue Version: openMittsu_0.9.11plus62-gfeea57a


    Hallo Philipp,


    ich freue mich, dass es nach so langer Zeit wieder was neues von OpenMittsu gibt. :)
    Während die letzte Version eigentlich nicht mehr so richtig brauchbar war, ist diese Version jetzt wieder richtig super geworden.

    • Relativ schnelle Ladezeit beim Start. (Bei der alten Version kam es schon vor, dass man 2-3 Stunden warten musste, bis man damit schreiben konnte)
    • Das Laden der Historie geht auch sehr schnell.
    • Die Unterteilung der Kontaktliste und Gruppen ist jetzt super und sehr übersichtlich geworden.


    Ingesamt macht das Arbeiten mit OpenMittsu jetzt wieder richtig viel Spaß! :)


    Vielen Dank für deine tolle Arbeit! :) :) :)

  • Bug gefixt ;)


    Neue Version: openMittsu_0.9.12plus3-g0d80a34


    Windows Binaries:


    Debian 9 Binaries: Siehe https://downloads.openmittsu.de/deb/ für Pakete plus Anleitung.
    Jetzt mit i386, armhf (Raspberry Pi) und amd64!
    AppImage: https://bintray.com/blizzard45…tly-Linux-x86_64.AppImage


    Ich freue mich auf Rückmeldung!